You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
66 lines
2.2 KiB
66 lines
2.2 KiB
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org> |
|
# Contributor: Ionut Biru <ibiru@archlinux.org> |
|
_froggy_highlight_color=#839942 |
|
|
|
pkgname=gtk3-froggy |
|
pkgver=3.24.30+126+g34038aaf7d |
|
pkgrel=1 |
|
epoch=1 |
|
pkgdesc="Provides normal gtk3 with a froggy highlight color for the Adwaita theme, you can even edit the PKGBUILD to change to color" |
|
arch=(x86_64) |
|
url="https://www.gtk.org/" |
|
depends=(atk cairo libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2 |
|
dconf libxcomposite libxdamage pango shared-mime-info at-spi2-atk |
|
wayland libxkbcommon adwaita-icon-theme json-glib librsvg |
|
wayland-protocols desktop-file-utils mesa cantarell-fonts colord rest |
|
libcups libcanberra fribidi iso-codes tracker3 libcloudproviders |
|
gtk-update-icon-cache) |
|
makedepends=(gobject-introspection gtk-doc git glib2-docs sassc meson) |
|
provides=(gtk3=3.24.30 gtk3-print-backends libgtk-3.so libgdk-3.so libgailutil-3.so) |
|
conflicts=(gtk3=3.24.30 gtk3-print-backends) |
|
replaces=("gtk3-print-backends<=3.22.26-1") |
|
license=(LGPL) |
|
install=gtk3.install |
|
source=('git+https://gitlab.gnome.org/GNOME/gtk.git#branch=gtk-3-24' |
|
gtk-query-immodules-3.0.hook) |
|
sha256sums=('SKIP' |
|
'a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229') |
|
|
|
pkgver() { |
|
cd gtk |
|
git describe --tags | sed 's/-/+/g' |
|
} |
|
|
|
prepare() { |
|
cd gtk |
|
sed -i "s/#3584e4/$_froggy_highlight_color/" gtk/theme/Adwaita/_colors.scss |
|
sed -i "s/darken(#3584e4, 20%)/$_froggy_highlight_color/" gtk/theme/Adwaita/_colors.scss |
|
cp ../../assets.svg gtk/theme/Adwaita/assets.svg |
|
} |
|
|
|
build() { |
|
CFLAGS+=" -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS" |
|
arch-meson gtk build \ |
|
-D broadway_backend=true \ |
|
-D cloudproviders=true \ |
|
-D colord=yes \ |
|
-D gtk_doc=true \ |
|
-D man=true |
|
meson compile -C build |
|
} |
|
|
|
package() { |
|
DESTDIR="$pkgdir" meson install -C build |
|
|
|
install -Dm644 /dev/stdin "$pkgdir/usr/share/gtk-3.0/settings.ini" <<END |
|
[Settings] |
|
gtk-icon-theme-name = Adwaita |
|
gtk-theme-name = Adwaita |
|
gtk-font-name = Cantarell 11 |
|
END |
|
|
|
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 gtk-query-immodules-3.0.hook |
|
|
|
rm "$pkgdir/usr/bin/gtk-update-icon-cache" |
|
rm "$pkgdir/usr/share/man/man1/gtk-update-icon-cache.1" |
|
} |